Patient Data, Call History, and Voicemail Data Not Populating

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 14:53 MDT

Update

Patient lists are currently not loading in Weave. This does also affect creating a payment request for things like terminal payments and manual card entry. Online Bill Pay is currently still operational and patients can pay over those links. We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 13:11 MDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 12:49 MDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 30, 2025 - 11:55 MDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Oct 30, 2025 - 10:27 MDT
This incident affected: Payments and Weave Portal.