Payment Requests Loading Slowly

Incident Report for Weave

Resolved

This incident has been resolved. Thank you for your patience.
Posted Apr 02, 2025 - 15:13 MDT

Identified

We've received reports of some customers having slowness when making payment requests. The team have identified the issue, and are working toward a resolution.
Posted Apr 02, 2025 - 14:01 MDT