10DLC Registration
Incident Report for Weave
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 14:53 MST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 14:53 MST
Investigating
We are currently experiencing high volume in our customer support queues due to offices looking to register their 10DLC campaigns. Please know that you can register your own campaign by following the instructions in the following help article https://www.weavehelp.com/weavehelp/article/register-your-text-messaging-brand-through-weave

Please be aware that Sole Proprietors must register an EIN: https://www.weavehelp.com/weavehelp/article/text-messaging-brand-registration-faq

If your registration was rejected please be sure to follow all the instructions in the article before contacting support.
Posted Nov 13, 2024 - 13:56 MST