Dentrix Ascend Patient Data Not Syncing

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 15:50 MDT

Monitoring

A fix has been implemented and we are currently monitoring. Thank you for your patience.
Posted Apr 01, 2026 - 12:51 MDT

Investigating

We are investigating an issue causing patient data to not sync.
Posted Apr 01, 2026 - 08:04 MDT
This incident affected: Weave Portal.