Calls continuing to ring even after being picked up

Incident Report for Weave

Resolved

This issue has been resolved.
Posted Jun 02, 2025 - 09:24 MDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jun 02, 2025 - 09:20 MDT

Identified

The issue of calls continuing to ring even after being picked up has been identified, and we are working on a resolution.
Posted Jun 02, 2025 - 09:11 MDT
This incident affected: Phone Service.