Weave inbox out of order

Incident Report for Weave

Resolved

This incident has been resolved!
Posted Mar 09, 2026 - 15:55 MDT

Identified

The issue has been identified and we are working on a fix.
Posted Mar 09, 2026 - 14:32 MDT

Investigating

We are currently looking into why your Weave Messaging inbox is appearing out of chronological order.
Posted Mar 09, 2026 - 12:44 MDT
This incident affected: SMS (texting) Service and Desktop Application.