Delay sending Faxes

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 09:09 MST

Identified

This issues has been identified and customers are not able to send Fax but we are working with our third party provider to resolve this issue.
Posted Feb 23, 2026 - 08:52 MST

Investigating

We are currently investigating with our third-party provider on why some faxes are being delayed in sending.
Posted Feb 23, 2026 - 08:25 MST
This incident affected: Fax Service.