Third-Party Integration Outage (NexHealth)

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 12:02 MDT

Monitoring

A fix has been implemented. We are monitoring the results.
Posted Jul 10, 2026 - 11:59 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 10, 2026 - 11:52 MDT

Investigating

We are investigating reported API failures with our third-party partner, NexHealth. This may affect some dependent services. We're working to resolve the issue and will share updates as they become available.
Posted Jul 10, 2026 - 11:19 MDT