Faxs fail to load
Incident Report for Weave
Resolved
This issue is now resolved.
Posted Jan 08, 2024 - 10:57 MST
Investigating
We are currently investigating reports of our fax feature failing to load.
Posted Jan 08, 2024 - 10:30 MST
This incident affected: Fax Service.