Weave Insurance Verification "Verification Failed" Error

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 15:20 MST

Monitoring

A fix has been implemented and we are monitoring the result
Posted Dec 10, 2025 - 15:17 MST

Update

We indentified the issue and we are continue to work with our third-party provider to make verifications operational again
Posted Dec 10, 2025 - 12:26 MST

Identified

Due to our third-party's vendors services currently being down, manual verification will continue to fail.
Posted Dec 10, 2025 - 12:12 MST
This incident affected: Desktop Application.