Unable to Print Preview faxes
Incident Report for Weave
Resolved
We have found the issue and have implemented a fix. This is now resolved.
Posted Jul 22, 2024 - 10:22 MDT
Investigating
We are receiving reports of being unable to print preview faxes. We are currently investigating this issue.
Posted Jul 22, 2024 - 09:39 MDT
This incident affected: Fax Service.