Support Center Phones Down
Incident Report for Weave
Resolved
This incident has been resolved. We will resume regular business hours tomorrow at 6am Mountain
Posted Jan 10, 2024 - 18:23 MST
Investigating
We are currently investigating an issue with our Support telephony system.
There is no impact to the Weave phone system that customers use.

If you need to contact support, please visit us at https://www.weavehelp.com/hc/en-us/p/contact-us and we'd be happy to live chat with you there!
Additionally, the support team can be reached at support@getweave.com via email.
Posted Jan 10, 2024 - 15:55 MST