Error when launching kiosk mode

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 15:59 MDT

Investigating

We've received reports of some customers getting error "secure connection failed" when launching kiosk mode. Our teams are investigating.
Posted Jun 02, 2025 - 13:36 MDT