User log in error

Incident Report for Weave

Resolved

This incident is Resolved!
Posted Sep 25, 2023 - 11:42 MDT

Investigating

We are currently investigating why users can not Log into their Weave desktop client or their Weave admin portal. We have found a workaround. We ask all customers to update their Google Chrome to the Latest version in order to bypass the login error you currently are seeing.
Posted Sep 25, 2023 - 07:54 MDT
This incident affected: Desktop Application and Weave Portal.