Fax Loading Delay/Unable to Send Faxes

Incident Report for Weave

Resolved

This issue has been resolved.
Posted Jun 03, 2025 - 14:32 MDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Jun 03, 2025 - 10:48 MDT

Investigating

We are currently investigating the issue of delayed fax page loading, and an error when sending faxes.
Posted Jun 03, 2025 - 10:28 MDT
This incident affected: Fax Service.