Super Admins May Have Difficulty Loading Weave

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 20:07 MST

Identified

We received reports of some Super Admins having difficulty loading Weave. Our Engineering staff are aware of the problem, have created a fix, and are in the process of implementing this. Thank you for your patience.
Posted Dec 18, 2025 - 16:59 MST