Reports of payment plan details not showing up
Incident Report for Weave
Resolved
A fix has been deployed to address the issue.
Our teams are monitoring the fix to ensure the issue is resolved.
Posted Mar 11, 2024 - 17:08 MDT
Identified
The issue has been identified and we are working to implement a fix
Posted Mar 11, 2024 - 16:04 MDT
Investigating
We have received some reports of customers indicating that when they attempt to pull up payment plan details, they are unable to surface results. Our teams are currently investigating.
Posted Mar 11, 2024 - 15:45 MDT
This incident affected: Payments.