Required 10DLC Registration

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Nov 13, 2024 - 14:54 MST

Monitoring

URGENT! All businesses are required to register for 10DLC. Any businesses that have yet to register may result in your text messages being blocked by wireless carriers and potential increased fees.

For more information on how to register your business, please reference the instructions found on this article: https://www.weavehelp.com/hc/en-us/articles/10424273788827
Posted Apr 24, 2023 - 15:11 MDT
This incident affected: SMS (texting) Service.