Desktop/Mobile/Portal - Messages - Message history not showing
Incident Report for Weave
Resolved
The incident was resolved. Thank you for your patience.
Posted Dec 02, 2024 - 23:35 MST
Investigating
We are currently Looking into this issue.
Posted Dec 02, 2024 - 17:53 MST
This incident affected: SMS (texting) Service.