Issues calling into Weave Support

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Sep 08, 2023 - 12:32 MDT

Investigating

Our telephony provider indicated that they are currently investigating an issue that may cause issues when calling Weave Support. We are working with them to resolve quickly.
Posted Sep 07, 2023 - 11:03 MDT