Click to dial in Weave applications
Incident Report for Weave
Resolved
We have resolved the issue with click to call.
Posted Sep 25, 2024 - 09:29 MDT
Investigating
We are currently investigating issues with Click to Call when trying to dial a number from Weave software.
Posted Sep 25, 2024 - 08:55 MDT
This incident affected: Desktop Application.