Payments not writing back into Eaglesoft

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 09:53 MDT

Investigating

We are currently investigating on why some customers payments are not writing back into their practice management software Eaglesoft and Opendental.
Posted Apr 30, 2025 - 08:31 MDT
This incident affected: Payments.