Issues contacting Weave support

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 19:36 MDT

Monitoring

A fix has been implemented, and Weave Support is now able to receive calls. We are actively monitoring the situation.
Posted Aug 05, 2025 - 17:31 MDT

Update

We’re currently working with our phone service provider to fix an issue that’s preventing us from receiving calls to Weave Support. We're available to assist you via email and chat at weavehelp.com (click on the question mark in the lower right hand corner to start a chat session).

Please note: This issue does not impact your Weave phone service.
Posted Aug 05, 2025 - 14:59 MDT

Identified

Our third-party provider has identified the issue affecting calls to our inbound support line. We’re actively working with their telephony systems engineering teams to restore service as quickly as possible. In the meantime, please reach out to us via chat at weavehelp.com.
Posted Aug 05, 2025 - 13:09 MDT

Investigating

We’re currently investigating sporadic issues affecting customer connections to Weave Support. If you’re experiencing trouble reaching us by phone, please connect with us via chat or email at weavehelp.com for prompt assistance.
Posted Aug 05, 2025 - 10:28 MDT