Problems accessing some features and functionality

Incident Report for Weave

Resolved

This incident has been resolved
Posted Aug 27, 2026 - 17:56 MDT

Investigating

We are currently investigating this issue
Posted Aug 27, 2026 - 14:42 MDT
This incident affected: Desktop Application.