Nexhealth Api failing for Truelark Customers

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 16:27 MDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 07, 2026 - 16:24 MDT

Update

We are continuing to investigate this issue.
Posted Apr 07, 2026 - 16:03 MDT

Update

Our Engineering team are currently working with Nexhealth to determine cause and mitigate impact.
Posted Apr 07, 2026 - 16:00 MDT

Investigating

We are currently investigating why the Nexhealth API calls are failing.
Posted Apr 07, 2026 - 16:00 MDT