Degradation with Mindbody Integration Services

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 12:25 MDT

Monitoring

We are seeing signs of recovery and are moving to monitoring.
Posted Jul 22, 2026 - 11:48 MDT

Investigating

We are currently investigating an issue impacting our integration with Mindbody booking software. Due to a third-party outage on Mindbody's end, customers with this integration type may experience errors or failures within Weave when attempting to:

Search customer profiles
Search appointment availability
Book, cancel, or reschedule appointments

We are actively monitoring the situation alongside Mindbody and will provide updates as new information becomes available.
Posted Jul 22, 2026 - 11:28 MDT