Reports of being Unable to Take Callers Off Hold

Incident Report for Weave

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 14:53 MDT

Investigating

We have received reports of offices having issues with being able to take callers out of a hold/park after placing the caller on hold/park. Our teams are currently investigating.
Posted Oct 30, 2025 - 13:26 MDT
This incident affected: Phone Service.