Support Contact Center Service Interruption
Incident Report for Weave
Resolved
This issue is now resolved.
Posted Mar 19, 2024 - 16:02 MDT
Investigating
We are currently investigating an issue reaching our Contact Center (Weave Support) by phone.
Please feel free to chat with us as we work to get the issue resolved
https://www.weavehelp.com/hc/en-us/p/contact-us

No Weave products have been impacted by this.
Posted Mar 19, 2024 - 15:05 MDT